PT Cruiser Network

PT Cruiser Network

Technical (82)

Discussions Replies Latest Activity

Help Fenders

Hi All, New to this site and I need a little help. My wife has a 2006 and had a little fender bender. She backed into my truck in our drive…

Started by Dan Bevan

0 Oct 15

Seat

Does anyone know if there is a mod for lowering the drivers seat?

Started by Mark Gilbert

0 Jan 29

PT Overheating issue

Dear Friends, I was advised to join a PT network to get some advice on mechanical issues with my PT. I am having an overheating problem and…

Started by Cynthia A. Handly

2 Jul 23, 2016
Reply by Roy Sakabu

PUSH START BUTTON INSTALLATION ON PT

Our new member Ray has a question for our members below.  Can anyone give him some direction and assistance? I am having a bit of a problem…

Started by Gary 'TAZ' McCullough

1 Apr 5, 2015
Reply by Russell and Julia Haynes

Hesitation and stumbling when brakes applied

I have an '04 Limited with 70,000 miles. After it warms up, while sitting at a light with the brakes applied, the engine stumbles and misse…

Started by gerry lopez

5 Apr 5, 2015
Reply by gerry lopez

Hatch Struts

I have a 2002 P/T and have to replace the rear hatch struts, how hard off a job is it??

Started by Don "Duck" Kohlbeck

3 Dec 4, 2014
Reply by Don "Duck" Kohlbeck

Leaky Seal on Convertible

2006 Convertible GT: The seal around the side windows and top has started leaking.  It looks like it is sealed but the least bite of rain a…

Started by Tony and Carolyn Lombard

0 Aug 21, 2014

Anybody had this issue?

06 Base Cruiser. About 2 months ago while driving to work all the dash lights came on for about 2 seconds and then went off about 4 or 5 ti…

Started by Donald W Duvall

2 Aug 17, 2014
Reply by Richard Westcott

Little lights

Has anyone had the experience of replacing the little lights in the window switches on the dash? I have 3 out of 4 out. The only one that l…

Started by Danny Butler

9 Jul 20, 2014
Reply by Donald W Duvall

ELECTRICAL FAULT

Hello Again , I have an electrical fault, all my left hand side indicators are not working I have been told it is possibly the relay and am…

Started by Alan

2 Jun 12, 2014
Reply by ptgeebee - Gordon

RSS

Badge

Loading…

© 2017   Created by Terry.   Powered by

Badges  |  Report an Issue  |  Terms of Service